using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Cursus risus at .* mi tempus imperdiet";
string input = @"Cursus risus at ultrices mi tempus imperdiet
Cursus risus at scelerisque mi tempus imperdiet";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}