re = /Cursus risus at .* mi tempus imperdiet/m
str = 'Cursus risus at ultrices mi tempus imperdiet
Cursus risus at scelerisque mi tempus imperdiet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end