$re = '/Cursus risus at .* mi tempus imperdiet/m';
$str = 'Cursus risus at ultrices mi tempus imperdiet
Cursus risus at scelerisque mi tempus imperdiet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);