package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<console>(?:\/\/)?\s*console\.(?<function>[^(]+)[^;]+;)`)
var str = `//console.log(abc)
// console.log(abc)
// console.log(abc);
// console.log('abc');
console.log(abc);
console.log('abc' + some_function());
console.alert('some teststring');`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}