re = /(?<console>(?:\/\/)?\s*console\.(?<function>[^(]+)[^;]+;)/
str = '//console.log(abc)
// console.log(abc)
// console.log(abc);
// console.log(\'abc\');
console.log(abc);
console.log(\'abc\' + some_function());
console.alert(\'some teststring\');'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end