$re = '/(?<console>(?:\/\/)?\s*console\.(?<function>[^(]+)[^;]+;)/';
$str = '//console.log(abc)
// console.log(abc)
// console.log(abc);
// console.log(\'abc\');
console.log(abc);
console.log(\'abc\' + some_function());
console.alert(\'some teststring\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);