package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#[^ #.]+`)
var str = `Olá, estou postando essa #pergunta no #stackoverlow. Espero que encontre boas #respostas.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}