re = /#[^ #.]+/m
str = 'Olá, estou postando essa #pergunta no #stackoverlow. Espero que encontre boas #respostas.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end