$re = '/#[^ #.]+/m';
$str = 'Olá, estou postando essa #pergunta no #stackoverlow. Espero que encontre boas #respostas.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);