using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(c\.)\d+[\+,\-]\d+";
string input = @"c.288+105G>A
c.414_415delCT
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}