$re = '/(c\.)\d+[\+,\-]\d+/';
$str = 'c.288+105G>A
c.414_415delCT
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);