package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(c\.)\d+[\+,\-]\d+`)
var str = `c.288+105G>A
c.414_415delCT
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}