using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https:\/\/)[^\s/$.?#].[^\s]*(\.msappproxy\.net)$";
string input = @"https://www.maynewayent.com
www.maynewayent com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}