re = /^(https:\/\/)[^\s\/$.?#].[^\s]*(\.msappproxy\.net)$/
str = 'https://www.maynewayent.com
www.maynewayent com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end