package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(https:\/\/)[^\s/$.?#].[^\s]*(\.msappproxy\.net)$`)
var str = `https://www.maynewayent.com
www.maynewayent com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}