using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+|1\s?)?(\([0-9]{3}\)\s?|[0-9]{3}\-?)([0-9]{3}\-?|[0-9]{3}\s?)[0-9]{4}$";
string input = @"1 555 555 5555
1 456 789 4444";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}