import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+|1\\s?)?(\\([0-9]{3}\\)\\s?|[0-9]{3}\\-?)([0-9]{3}\\-?|[0-9]{3}\\s?)[0-9]{4}$";
final String string = "1 555 555 5555\n"
+ "1 456 789 4444";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}