package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\+?)(1?(\-?)?))(\d{3})(-|\s)?\d{3}(-|\s)?\d{4}$`)
var str = `444-666-1232
1-234-123-1234
1234-123-1234
+1234-123-1234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}