$re = '/^((\+?)(1?(\-?)?))(\d{3})(-|\s)?\d{3}(-|\s)?\d{4}$/m';
$str = '444-666-1232
1-234-123-1234
1234-123-1234
+1234-123-1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);