import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\+?)(1?(\\-?)?))(\\d{3})(-|\\s)?\\d{3}(-|\\s)?\\d{4}$";
final String string = "444-666-1232\n"
+ "1-234-123-1234\n"
+ "1234-123-1234\n"
+ "+1234-123-1234\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}