const regex = /<tag_([A-Z0-9]*)\b[^>]*>.*?<tag_([A-Z0-9]*)\b[^>]*>[^\/]*?(?!(\/tag_\2))\/tag_\1>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<tag_([A-Z0-9]*)\\b[^>]*>.*?<tag_([A-Z0-9]*)\\b[^>]*>[^\\\/]*?(?!(\\\/tag_\\2))\\\/tag_\\1>', 'gi')
const str = `<tag_1> xx <tag_2> xx </tag_1> xx </tag_2> xx <tag_1> xx <tag_3> xx <tag_4> xx </tag_4> xx </tag_3> </tag_1>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}