re = /<tag_([A-Z0-9]*)\b[^>]*>.*?<tag_([A-Z0-9]*)\b[^>]*>[^\/]*?(?!(\/tag_\2))\/tag_\1>/i
str = '<tag_1> xx <tag_2> xx </tag_1> xx </tag_2> xx <tag_1> xx <tag_3> xx <tag_4> xx </tag_4> xx </tag_3> </tag_1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end