using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+ \w+\s+={37}\s+Table tablespaces do not match\. Destination : SUM_DEMO_(\w+) Source : SFDEV_(\1)";
string input = @" ADM_RPT_COL
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT
ADM_RPT_HDR
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT
ADM_USER_PREF
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_INFMT_DAT ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}