using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">\s*([^<>]*)<div class=""tag"" data-id=\""([^\""]*?)\"">([^<>]*?)<\/div>";
string input = @"<div id=""tarea"" contentEditable=""true"" class=""tarea"" autocorrect=""false"" spellCheck=""off"">
Hello Says! <div class=""tag"" data-id=""1005"">Vedant Terkar</div> , <br />To all <div class=""tag"" data-id=""1006"">SO Users</div> :-).
</div>
<!-- This textarea is Usually Hidden -->
<textarea id=""opc"" rows=""5"" cols=""97"">
</textarea>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}