package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`>\s*([^<>]*)<div class="tag" data-id=\"([^\"]*?)\">([^<>]*?)<\/div>`)
var str = `<div id="tarea" contentEditable="true" class="tarea" autocorrect="false" spellCheck="off">
Hello Says! <div class="tag" data-id="1005">Vedant Terkar</div> , <br />To all <div class="tag" data-id="1006">SO Users</div> :-).
</div>
<!-- This textarea is Usually Hidden -->
<textarea id="opc" rows="5" cols="97">
</textarea>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}