import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">\\s*([^<>]*)<div class=\"tag\" data-id=\\\"([^\\\"]*?)\\\">([^<>]*?)<\\/div>";
final String string = "<div id=\"tarea\" contentEditable=\"true\" class=\"tarea\" autocorrect=\"false\" spellCheck=\"off\">\n"
+ " Hello Says! <div class=\"tag\" data-id=\"1005\">Vedant Terkar</div> , <br />To all <div class=\"tag\" data-id=\"1006\">SO Users</div> :-).\n"
+ "</div>\n"
+ "<!-- This textarea is Usually Hidden -->\n"
+ "<textarea id=\"opc\" rows=\"5\" cols=\"97\">\n"
+ "</textarea>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}