#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.*:)."
Local $sString = "Hilary: YOU KNOW, THIS IS NOT WHY I CAME HERE." & @CRLF & _
"" & @CRLF & _
"Devon: DOESN'T MATTER." & @CRLF & _
"" & @CRLF & _
"Hilary: IT DOES. DEVON, WHEN I SAY THAT I'M TIRED OF SNEAKING AROUND, I MEANT IT." & @CRLF & _
"" & @CRLF & _
"Devon: DON'T GET UPSET, THOUGH." & @CRLF & _
"" & @CRLF & _
"Hilary: HOW CAN I NOT? I MEAN, LOOK AT WHAT I DID." & @CRLF & _
"" & @CRLF & _
"Devon: HONEY, HONEY, WE'RE IN LOVE WITH EACH OTHER. OKAY? AND WE KNOW EXACTLY WHAT WE HAVE TO DO. WE'RE GONNA TELL NEIL THE TRUTH." & @CRLF & _
"" & @CRLF & _
"Hilary: NOW?" & @CRLF & _
"" & @CRLF & _
"Dr. Barrett: I THINK YOU CAN PROVIDE SOME VALUABLE INSIGHT INTO PHYLLIS NEWMAN'S RECENT STATE OF MIND."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")