import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.*:).";
final String string = "Hilary: YOU KNOW, THIS IS NOT WHY I CAME HERE.\n\n"
+ "Devon: DOESN'T MATTER.\n\n"
+ "Hilary: IT DOES. DEVON, WHEN I SAY THAT I'M TIRED OF SNEAKING AROUND, I MEANT IT.\n\n"
+ "Devon: DON'T GET UPSET, THOUGH.\n\n"
+ "Hilary: HOW CAN I NOT? I MEAN, LOOK AT WHAT I DID.\n\n"
+ "Devon: HONEY, HONEY, WE'RE IN LOVE WITH EACH OTHER. OKAY? AND WE KNOW EXACTLY WHAT WE HAVE TO DO. WE'RE GONNA TELL NEIL THE TRUTH.\n\n"
+ "Hilary: NOW?\n\n"
+ "Dr. Barrett: I THINK YOU CAN PROVIDE SOME VALUABLE INSIGHT INTO PHYLLIS NEWMAN'S RECENT STATE OF MIND.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}