$re = '/(?!.*:)./m';
$str = 'Hilary: YOU KNOW, THIS IS NOT WHY I CAME HERE.
Devon: DOESN\'T MATTER.
Hilary: IT DOES. DEVON, WHEN I SAY THAT I\'M TIRED OF SNEAKING AROUND, I MEANT IT.
Devon: DON\'T GET UPSET, THOUGH.
Hilary: HOW CAN I NOT? I MEAN, LOOK AT WHAT I DID.
Devon: HONEY, HONEY, WE\'RE IN LOVE WITH EACH OTHER. OKAY? AND WE KNOW EXACTLY WHAT WE HAVE TO DO. WE\'RE GONNA TELL NEIL THE TRUTH.
Hilary: NOW?
Dr. Barrett: I THINK YOU CAN PROVIDE SOME VALUABLE INSIGHT INTO PHYLLIS NEWMAN\'S RECENT STATE OF MIND.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);