package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*(Microsoft-Windows-InternetExplorer-).*(11\.).*(\.mum))$`)
var str = `Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~11.2.9600.16428.mum`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}