import re
regex = re.compile(r"(.*(Microsoft-Windows-InternetExplorer-).*(11\.).*(\.mum))$")
test_str = "Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~11.2.9600.16428.mum"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")