import Foundation
let pattern = #"(.*(Microsoft-Windows-InternetExplorer-).*(11\.).*(\.mum))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Microsoft-Windows-InternetExplorer-Package-TopLevel~31bf3856ad364e35~x86~~11.2.9600.16428.mum"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}