using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:\.\d+)?(?=(?:[^[\]]*\[[^[\]]*\])*[^[\]]*$)";
string input = @"[B.TARGET.avg(37)]*2 + length(23)
[B.TARGET.avg(375)]*233 + length(233) + 2323.23 + [C(23)] as";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}