re = /\d+(?:\.\d+)?(?=(?:[^[\]]*\[[^[\]]*\])*[^[\]]*$)/
str = '[B.TARGET.avg(37)]*2 + length(23)
[B.TARGET.avg(375)]*233 + length(233) + 2323.23 + [C(23)] as'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end