import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:\\.\\d+)?(?=(?:[^[\\]]*\\[[^[\\]]*\\])*[^[\\]]*$)";
final String string = "[B.TARGET.avg(37)]*2 + length(23)\n\n"
+ "[B.TARGET.avg(375)]*233 + length(233) + 2323.23 + [C(23)] as";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}