#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=vertex\s)-?\d*\.?\d+|(?<=\G\s)-?\d*\.?\d+"
Local $sString = "vertex" & @CRLF & _
"144.64329 -65.95227 -40.5391" & @CRLF & _
"244.25595 -77.64196 -51.07746" & @CRLF & _
"144.64738 23.13064 -40.53168" & @CRLF & _
"244.26259 67.13464 -51.0654" & @CRLF & _
"144.64968 -65.94874 36.17572" & @CRLF & _
"244.26407 -77.63749 46.41944" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")