$re = '/(?<=vertex\s)-?\d*\.?\d+|(?<=\G\s)-?\d*\.?\d+/';
$str = 'vertex
144.64329 -65.95227 -40.5391
244.25595 -77.64196 -51.07746
144.64738 23.13064 -40.53168
244.26259 67.13464 -51.0654
144.64968 -65.94874 36.17572
244.26407 -77.63749 46.41944
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);