using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=vertex\s)-?\d*\.?\d+|(?<=\G\s)-?\d*\.?\d+";
string input = @"vertex
144.64329 -65.95227 -40.5391
244.25595 -77.64196 -51.07746
144.64738 23.13064 -40.53168
244.26259 67.13464 -51.0654
144.64968 -65.94874 36.17572
244.26407 -77.63749 46.41944
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}