package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`PV\{(\d+?(?:\.\d+){0,3})\}`)
var str = `PV{9}
PV{9.9}
PV{9.9.9}
PV{9.9.9.9}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}