$re = '/PV\{(\d+?(?:\.\d+){0,3})\}/';
$str = 'PV{9}
PV{9.9}
PV{9.9.9}
PV{9.9.9.9}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);