$re = '/^(?:(?:<[^<>]*>|<.*?>)*.){9}/m';
$str = 'Some <i>t</i>est <b>string</b> test
Some <i>t</i>est <b>string</b> test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);