package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:0|[+-]?[1-9][0-9]*)?\.[0-9]+$`)
var str = `float varieties:
4848.48
20.20
20.2000000
-1.23
-0.23
+1.1
0.45
+0.45
-0.45
0.0
0.00000
-0.0
+0.0
.3
-.4
+.4
+.30
00.1
+00001.1
01.45
+01.20
-00.2
int varieties:
1234
43210
12012
+1
0
-0
+0
01234
000001234
+00
-00
+00123
-00123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}