# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:0|[+-]?[1-9][0-9]*)?\.[0-9]+$"
test_str = ("float varieties:\n\n"
"4848.48\n"
"20.20\n"
"20.2000000\n"
"-1.23\n"
"-0.23\n"
"+1.1\n"
"0.45\n"
"+0.45\n"
"-0.45\n"
"0.0\n"
"0.00000\n"
"-0.0\n"
"+0.0\n"
".3\n"
"-.4\n"
"+.4\n"
"+.30\n"
"00.1\n"
"+00001.1\n"
"01.45\n"
"+01.20\n"
"-00.2\n\n\n"
"int varieties:\n\n"
"1234\n"
"43210\n"
"12012\n"
"+1\n"
"0\n"
"-0\n"
"+0\n"
"01234\n"
"000001234\n"
"+00\n"
"-00\n"
"+00123\n"
"-00123\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.