import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0|[+-]?[1-9][0-9]*)?\\.[0-9]+$";
final String string = "float varieties:\n\n"
+ "4848.48\n"
+ "20.20\n"
+ "20.2000000\n"
+ "-1.23\n"
+ "-0.23\n"
+ "+1.1\n"
+ "0.45\n"
+ "+0.45\n"
+ "-0.45\n"
+ "0.0\n"
+ "0.00000\n"
+ "-0.0\n"
+ "+0.0\n"
+ ".3\n"
+ "-.4\n"
+ "+.4\n"
+ "+.30\n"
+ "00.1\n"
+ "+00001.1\n"
+ "01.45\n"
+ "+01.20\n"
+ "-00.2\n\n\n"
+ "int varieties:\n\n"
+ "1234\n"
+ "43210\n"
+ "12012\n"
+ "+1\n"
+ "0\n"
+ "-0\n"
+ "+0\n"
+ "01234\n"
+ "000001234\n"
+ "+00\n"
+ "-00\n"
+ "+00123\n"
+ "-00123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}