using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\WPRIMARY\W*KEY\W?\()(?P<PRIMARY_KEY>[^)]+)|(?:\W*KEY\W?\()(?P<KEY>[^)]+)";
string input = @"'CREATE table ""msg"" ( ""myid"" INT(10) UNSIGNED , ""user"" INT(10) UNSIGNED , ""new_mes"" SMALLINT(5) UNSIGNED , ""total_mes"" MEDIUMINT(8) UNSIGNED , ""lastdate"" DATETIME , PRIMARY KEY (""ids""), KEY (""lastdate"") )'";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}