re = /(?:\WPRIMARY\W*KEY\W?\()(?P<PRIMARY_KEY>[^)]+)|(?:\W*KEY\W?\()(?P<KEY>[^)]+)/i
str = '\'CREATE table "msg" ( "myid" INT(10) UNSIGNED , "user" INT(10) UNSIGNED , "new_mes" SMALLINT(5) UNSIGNED , "total_mes" MEDIUMINT(8) UNSIGNED , "lastdate" DATETIME , PRIMARY KEY ("ids"), KEY ("lastdate") )\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end