const regex = /(?:\WPRIMARY\W*KEY\W?\()(?P<PRIMARY_KEY>[^)]+)|(?:\W*KEY\W?\()(?P<KEY>[^)]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\WPRIMARY\\W*KEY\\W?\\()(?P<PRIMARY_KEY>[^)]+)|(?:\\W*KEY\\W?\\()(?P<KEY>[^)]+)', 'gi')
const str = `'CREATE table "msg" ( "myid" INT(10) UNSIGNED , "user" INT(10) UNSIGNED , "new_mes" SMALLINT(5) UNSIGNED , "total_mes" MEDIUMINT(8) UNSIGNED , "lastdate" DATETIME , PRIMARY KEY ("ids"), KEY ("lastdate") )'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}