#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:\d*[a-z]){2}\d*$)[\da-z]{8}$"
Local $sString = "a123456b" & @CRLF & _
"1a2b3456" & @CRLF & _
"aa123456" & @CRLF & _
"123ab456" & @CRLF & _
"And the bad samples:" & @CRLF & _
"" & @CRLF & _
"1abcdefg2" & @CRLF & _
"a1234567b" & @CRLF & _
"abcdefgh" & @CRLF & _
"12345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")