use strict;
my $str = 'a123456b
1a2b3456
aa123456
123ab456
And the bad samples:
1abcdefg2
a1234567b
abcdefgh
12345678';
my $regex = qr/^(?=(?:\d*[a-z]){2}\d*$)[\da-z]{8}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}