import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:\\d*[a-z]){2}\\d*$)[\\da-z]{8}$";
final String string = "a123456b\n"
+ "1a2b3456\n"
+ "aa123456\n"
+ "123ab456\n"
+ "And the bad samples:\n\n"
+ "1abcdefg2\n"
+ "a1234567b\n"
+ "abcdefgh\n"
+ "12345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}